Home > Error Unable > Error Unable To Open Port Invalid Command Name Compiler.blacklist

Error Unable To Open Port Invalid Command Name Compiler.blacklist

Philip jacopo rocchi Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update Yes you are right. And when I search the net I get conflicting reports on this as well! Should I repair permissions and try again? I'd say it looks like (but as I don't have MacOSX I'm on slippery surface) you need to install some developer tools as well. check over here

I ran the selfupdate, and "Congratulations, you have successfully upgraded the MacPorts system." YAY!!! With Lion, the MySQL version got SO screwed up (there were "fixes" all over the Net, and then there were tons of people who never could get it fixed, like me) I thank you all for all your suggestions and helps. Therefore, the ticket can be closed.

Did you really need the latest statistics package? The new 'log' action can also be used to view the log for a port. *) Command line options can be abbreviated if unambiguous. *) New actions: rdeps, rdependents, setrequested, unsetrequested Then Mountain Lion came along and fixed the MySQL bug (finally). I have been trying everything imaginable to fix it, and was going to try to reinstall via MacPorts, hence this bug report.

I can't vouch for their performance and reliability, as OF packages aren't updated just for fun but often because important bugs have been fixed. I think I've no choice and will wait some weeks until these problem get fixed :(. Can you attach /opt/local/var/macports/sources/rsync.macports.org/release/base/config.log? Everything upgraded now without any problem.

I found a web page where there was file.dmg, it must have been something like sourceforge.org, but it apparently has only the latest version. thus i download it and then i typed pkg install io-1.3.3.tar but that's what i get: /Applications/Octave.app/Contents/Resources/bin//mkoctfile: line 378: /Applications/Octave.app/Contents/Resources/bin/gsed: No such file or directory make: *** [csvexplode.oct] Error 1 mkoctfile thus i download it and then i typed pkg install io-1.3.3.tar but that's what i get: /Applications/Octave.app/Contents/Resources/bin//mkoctfile: line 378: /Applications/Octave.app/Contents/Resources/bin/gsed: No such file or directory make: *** [csvexplode.oct] Error 1 mkoctfile If we had only known before what the real underlying issue was.....

comment:18 Changed 3 years ago by neverpanic (Clemens Lang) Take a look at the installer log (press command+L). If so, you should run the uninstall script for it: From memory: sudo /Developer/Library/uninstall-devtools --mode=all comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt) There's probably some overlap between Xcode 3.2.6's The fully thing behind this is that i uploaded the operating system just to use the statistic package (that needed a newer version of octave respect to the one i had, Finally, i got the latest version, that's the 3.7.7 and if i now try to install statistics i got the message statistics needs io >= 1.0.18 and thus, if if i

You probably wanted to have known this before you started I guess. http://octave.1599824.n4.nabble.com/octave-update-td4658725.html In any event, please refer to the information Fink gave you above (quoted again below). > We don't support updates from 10.7 to 10.9. > Check the 'Clean Upgrade' section of When upgrading or installing another port, I see that there are broken files and a broken port (gimp2), but MacPorts fails to rebuild gimp2 correctly. what should i do? [18:44:54] i couldn't get help from google [18:45:05] *** maxagaz has quit IRC [18:52:30] *** veonik has joined #macports [18:52:52] *** kateweb has joined #macports [18:55:43]

What does HR do for me? check my blog comment:7 Changed 4 years ago by ryandesign (Ryan Schmidt) Resolution set to invalid Status changed from new to closed Note: See TracTickets for help on using tickets. Since I have no idea how to do that in a good and clean way, I would be grateful for any advice. if i write on > the shell > sudo port install octave-devel +atlas+docs > i get: > Error: Unable to open port: invalid command name "compiler.blacklist-append" > while if i use

Last edited 3 years ago by [email protected]… (previous) (diff) comment:21 follow-up: ↓ 22 Changed 3 years ago by neverpanic (Clemens Lang) Resolution set to wontfix Status changed from new to closed That PhilipNienhuis Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update In reply to this post by jacopo rocchi http://fink.thetis.ig42.org/lists/index.php?phpLang=enBen _______________________________________________ Help-octave mailing list [hidden email] https://mailman.cae.wisc.edu/listinfo/help-octave jacopo rocchi Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave this content I'd assume it is either because you have Fink and/or Homebrew installed in parallel or that you migrated from an older version of MacOS X to 10.9 (?).

Any suggestion? If Lion or later, please upgrade to Xcode 4.6, then visit the Xcode application's Preferences window, click Downloads, and ensure the command line tools are installed and up to date. Luke) Did you run xcode-select --install after installing Mavericks?

Bought agency bond (FANNIE MAE 0% 04/08/2027), now what?

If so, it will run "gcc -v" and examine its output. This is not enough to use the statistics package 1.2.2 http://octave.sourceforge.net/statistics/but i tried to use the -nodeps flag and it worked giving some warning messages. Use: cd /opt/local/var/macports/sources/rsync.macports.org/release/base && sudo env PATH=/bin:/usr/bin CC=/usr/bin/llvm-gcc-4.2 ./configure --prefix=/opt/local --with-tclpackage=/Library/Tcl --with-install-user=root --with-install-group=admin --with-directory-mode=0777 --enable-readline comment:12 Changed 3 years ago by [email protected]… ah, ok sure. Ben _______________________________________________ Help-octave mailing list [hidden email] https://mailman.cae.wisc.edu/listinfo/help-octave PhilipNienhuis Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update

Apple's installer tells users this is only going to take a minute, but that's not true and we have no influence over that. IF you are determined to keep on trying 3.7.7+ (you have been warned repeatedly and explicitly, with very very good reasons, by Carlo), well then you can also try (HACKING / We're working on automating the creation of MacOS X bundles for each release of Octave. have a peek at these guys Plus I feel as dumb as the dumbest dumb thing. --AND-- !

You're a saint - thank you so much! I would be very happy to get some advice on how to avoid this compiler.blacklist problem. This should be attached to bug reports. which curl /usr/bin/curl Found an article on stackexchange saying to reinstall curl using MacPorts and when I tried it failed, saying my ports needed to be updated.

So I tried doing this as well. ! Related 2How to reserve the original variants while upgrading a port in MacPorts?0Creating Macports port which doesn't need installation, no dependency, only extract2Linking Boost Filesystem in XCode 3.2 (MacPorts)0installing sets/groups/collections of no configure: error: in `/opt/local/var/macports/sources/rsync.macports.org/release/base': configure: error: C compiler cannot create executables See `config.log' for more details comment:13 Changed 3 years ago by neverpanic (Clemens Lang) Now check for /opt/local/var/macports/sources/rsync.macports.org/release/base/config.log and Solution is to add sudo at the right place.

Only if all dependencies are there it tries the next step (installing). SO - any help appreciated. Any suggestion? The step that failed should have created this file in this directory.

I DO have xcode tools installed, as well as the latest XCode, and ALL software on my machine that's in the App Store is currently up-to-date. ! Theorems demoted back to conjectures Has Darth Vader ever been exposed to the vacuum of space? The Fink homepage indicates that they are currently in the process of making packages available. If a formula fails to build, uninstall MacPorts/Fink and try > again. > Error: No available formula for octave > Searching taps... > homebrew/science/octave > > so how should i proceed?